« スパイラル | トップページ | Ruby1.9.1で試してみる »

Ruby1.9.1でRMagickと思ったけれど

 RMagick の Windows 用バイナリパッケージは 1.8.6 用で、1.9.1 にインストールしてみても動作しない。自前でコンパイルしてみようかとも思ったのだけれど、あまり情報もないのでやめることにして、それならと Ubuntu で試してみようと思った。

 Virtual Box の Ubuntu 9.04 に Ruby-1.9.1-p243 (パッケージマネージャでいれたら 1.9.0-p0 だった。古すぎ)をインストールしてから、RMagick-2.10.0 をインストールしようとしたのだけれどエラーがでて止まる。setup.rb:655 で止まる。RMagick の extconf.rb を実行しようとして止まっているみたい。

 うーむ、よくわからん。

 gem でインストールしてみようかと思ったら zlib が見つからないとかいわれるし。1.9.1 で使えないと困るわけではないのだけれど、対応しているというからには試してみるかと思っただけなので、やめておくか。気が向いたらもうすこしやってみるかも。

|
|

« スパイラル | トップページ | Ruby1.9.1で試してみる »

コメント

コメントを書く



(ウェブ上には掲載しません)




トラックバック

この記事のトラックバックURL:
http://app.cocolog-nifty.com/t/trackback/28835/45736420

この記事へのトラックバック一覧です: Ruby1.9.1でRMagickと思ったけれど:

« スパイラル | トップページ | Ruby1.9.1で試してみる »