« なつのそら | トップページ | スピードレーサーはチョロQだと思う »

言語は変化するもの

 ふと Ruby 1.9.0 で試してみたら警告やらエラーやらで止まってしまった。「$KCODE は使わなくなる予定なんだよ」みたいなことをいう。いや「もう使わないんだよ」って感じ?

 これかな?

http://doc.loveruby.net/refm/api/view/spec/m17n#ruby18

 $KCODE の代わりに、# coding: xxxx を置けと。あとで試してみよう。

#どこかに 1.9.0 と 1.8.x までとでどこが違うのかという一覧とかあるだろうか?

|
|

« なつのそら | トップページ | スピードレーサーはチョロQだと思う »

コメント

コメントを書く



(ウェブ上には掲載しません)




トラックバック

この記事のトラックバックURL:
http://app.cocolog-nifty.com/t/trackback/28835/41733660

この記事へのトラックバック一覧です: 言語は変化するもの:

« なつのそら | トップページ | スピードレーサーはチョロQだと思う »